Author Topic: Can't run sai.exe (CreateProcess failed with error2) [rather not uninstall]  (Read 5875 times)

weeklykrisTopic starter

  • Newbie
  • *
  • Posts: 3
  • YearsYearsYearsYears
    • View Profile
i'm really distressed here because my sai was working fine, what, two days ago? a day ago? there was nothing wrong with it till i tried to open it now. a lot of what i see says "uninstall it" but im also seeing that that isnt working for some people.

problem here is that i have about 50 brushes on sai that i will not be able to find again online, and if uninstall sai, those are all gone, and im not ready for that.

is there anyway around this???

also, when i try to open it from its shortcut or even the file in my folders, it doesnt do anything. no error, nothing.
« Last Edit: March 23, 2015, 09:35:07 AM by weeklykris »

obtusity

  • Jr. Member
  • **
  • Posts: 90
  • YearsYearsYearsYearsYearsYears
    • View Profile
Some possibilities:
Are you by any chance trying to run start-sai.exe instead of sai.exe? If so, is it in the same folder as sai.exe? 
Have you moved the Sai folder?
Have you run a full anti-virus scan recently? 

weeklykrisTopic starter

  • Newbie
  • *
  • Posts: 3
  • YearsYearsYearsYears
    • View Profile
Some possibilities:
Are you by any chance trying to run start-sai.exe instead of sai.exe? If so, is it in the same folder as sai.exe?
Have you moved the Sai folder?
Have you run a full anti-virus scan recently?

i believe the shortcut is start-sai.exe but even when i went into the folder and clicked both, nothing was happening.
the sai folder has been in my downloads since i got it many moons ago
and i havent run a full on scan in... a pRetty long while

obtusity

  • Jr. Member
  • **
  • Posts: 90
  • YearsYearsYearsYearsYearsYears
    • View Profile
Installed any new brushes recently? I'm wondering about a corrupted configuration file, or Sai looking for a file in the wrong location. 
But please do run that virus scan, there is at least one malware that interferes with being able to run exe files. 

Do you have file extensions turned on? You were clicking on sai.exe, not sai.ssd? It didn't have an extra space, dot, or underscore? (sorry, basic stuff but just checking all the possibilities) 

Please try with sai.exe, not start-sai.exe - does it give a different error, or no error? Is there an error log file, and does it contain anything useful? (although that might just be fit for the install program) Try renaming sai.exe to saib.exe - does that run? 

weeklykrisTopic starter

  • Newbie
  • *
  • Posts: 3
  • YearsYearsYearsYears
    • View Profile
Installed any new brushes recently? I'm wondering about a corrupted configuration file, or Sai looking for a file in the wrong location.
But please do run that virus scan, there is at least one malware that interferes with being able to run exe files.

Do you have file extensions turned on? You were clicking on sai.exe, not sai.ssd? It didn't have an extra space, dot, or underscore? (sorry, basic stuff but just checking all the possibilities)

Please try with sai.exe, not start-sai.exe - does it give a different error, or no error? Is there an error log file, and does it contain anything useful? (although that might just be fit for the install program) Try renaming sai.exe to saib.exe - does that run?

i havent installed a brush in quite sometime, normally i just take the pre-given brushes and tinker with them.
i ran the scan and nothing serious came up besides programs on my computer that had issues.
im not sure what file extensions are, i apologize. the files name is in check, nothing wrong with it.
i tried with both extensions and an error doesnt even come up. it just refuses to open